Remove old versions of PHP


Browse by products and services

  • Applies to: VPS Hosting
    • Difficulty: Easy
    • Time Needed: 10
    • Tools Required: Account Center, Plesk, or cPanel access

Overview

For security purposes, it's recommended to remove old versions oh PHP as they reach their End Of Life (EOL). This process can quickly be done within Plesk or cPanel.

Plesk

Plesk Obsidian 18.0.35

  1. Log into Plesk.
  2. Select Tools & Settings.
  3. Select Updates.
    vps-plesk-02.png
  4. Select Add/ Remove Components.
    vps-plesk-03.png
  5. Select Web Hosting >> PHP interpreter versions.
  6. Select the outdated version of PHP, and then select Remove.
    vps-plesk-07-replace.png
  7. Select Continue.
  8. After a few minutes, confirmation window will appear.

WHM

  1. Log into WHM.
  2. In the left menu, select Easy Apache 4.
    vps-whm-01.png
  3. At the top, select Customize for your current profile.
    vps-whm-02.png
  4. Select PHP Versions.
  5. Select the PHP Version you wish to uninstall.
    vps-whm-04.png
  6. Select Review.
  7. Scroll to the bottom and select Provision.
  8. Select Done.

Resources