Grid: PHP 5.3 EOL


Browse by products and services

    • APPLIES TO: GRID
      • Difficulty: N/A
      • Time Needed: N/A
      • Tools Required: N/A

Overview

We are removing PHP 5.3 from all legacy Grid Servers on clusters (c01 - c11). You can find out which cluster you are on by logging into your Account Center: How to find your Grid Cluster and Storage Segment

If you'd like to see see what PHP version your site is running on, you can create a php info page by following these instructions: How can I create a phpinfo.php page?

You also have the option to update your PHP version early through your Media Temple account: How do I change PHP versions?

FAQ

When will this happen?

We will be removing PHP 5.3 from all legacy Grids beginning on June 3rd, 2019. Support requests will be sent to notify customers regarding this change.

Why are we getting rid of PHP 5.3?

PHP 5.3 is considered End of Life and has been since August 2014. At this point, PHP 5.3 is no longer getting security updates and we want to make sure that customers are using more modern versions.

What versions of PHP are security supported?

PHP security support for 5.6 and 7.0 has ended, December 2018. At this time we will continue to offer them with no immediate plans to remove them. PHP 5.6 is still widely used across the internet, though the industry is moving towards PHP 7+.
http://php.net/supported-versions.php

What versions of PHP will be available on legacy Grids?

PHP 5.6.21 (Legacy)
PHP 5.6.21 (Stable)
PHP 7.2 (Latest)

What versions of PHP will be available on newer c10 and c12 Grids?

We will continue to offer PHP 5.6 and PHP 7 on Cluster 12. These versions will not change:

PHP 5.6.21 (Stable)
PHP 7.2 (Latest)

What will happen to sites that are using PHP 5.3?

Their PHP version will automatically update to PHP 5.6.

What has changed between PHP 5.3 and 5.6?

Quite a bit. We would highly recommend looking through the migration manuals between 5.3 and 5.6, specifically, the sections regarding backwards incompatible changes, deprecated features, and changes to INI handling.

http://php.net/manual/en/migration54.php
http://php.net/manual/en/migration55.php
http://php.net/manual/en/migration56.php

While there are too many to list, you may see issues if your site or applications are still using magic_quotes or register_globals in their php.ini. You may also come across errors regarding a mysql_list_dbs function which has been replaced with MySQLi or PDO_MySQL, or a “SHOW DATABASES” query.

Will my site or applications experience errors due to a PHP upgrade?

If your site is running on PHP 5.3, there is the possibilty of depreciated functions once the upgrade is implemented. To avoid this, we recommend having your developer update code, CMS, and/or other applications so that those functions are no longer used.

What if my site or application only works on PHP 5.3?

It is highly recommended to try and update to a PHP version that is still receiving security updates. However, if you require a temporary solution, while your developers update your site/application to a modern version, you can consider migrating your site to a Plesk DV server, which will allow for the install of PHP 5.3.

For information on migrating from a Grid to a DV, feel free to review our article here.

What about PECL extensions and custom packages?

It’s very possible that your developers will need to re-compile custom extensions that were compiled specifically for PHP 5.3. Be sure to check error logs as that should hint if there is an issue loading extensions.

You can also check your php.ini file to see if there are any custom extensions. These may look similar to the following:

extension_dir=/home/00000/path/to/extension
extension = yourPECLextension.so

Media Temple Support

If you have further questions before or after these changes have been implemented, feel free to reach out to our 24/7 Support Team by opening a support request, starting a chat, or by calling us at 1.310.841.5500.

However, do keep in mind that troubleshooting the configuration/functionality of third-party applications is not covered by our statement of support. And so there may be instances where you will also need to reach directly out to your website developers for assistance in making changes to your website or applications.

Resources