PHP 7.2.12 Now Supported on Media Temple's Grid Service

PHP 7.2 Now Supported

We are pleased to share that we have updated the PHP version 7.0.6 on Media Temple’s Grid service with the more stable and more secure PHP version 7.2.12.

PHP 7.0 has been unsupported (http://php.net/eol.php) since December 2018. This means that this version will no longer receive security updates and is not recommended by PHP developers. For security and stability reasons, it’s time for us to remove it from our systems.

If you are currently using PHP 7.0.6, you will be automatically updated to the new version. You can log into your Media Temple Account Center to determine what version of PHP each of your sites is using. For information on how you can specify the PHP version on your Grid service, check out this Media Temple Community article.

If your application experiences problems with this update, please make sure that your application is compatible with PHP 7.2. Enabling additional error logging may help provide some insight into any application issues you are having.

Please be aware that there are some deprecated features that we anticipate will have little impact on a majority of websites. You can review the differences in the following documents from the development team at PHP:

http://php.net/manual/en/migration71.php

http://php.net/manual/en/migration72.php

A large number of websites on the internet still use older versions of PHP. While we will still continue to offer PHP 5.6, our team will be removing PHP 5.3 in the near future as it has been unsupported for quite some time. The removal of PHP 5.6 will be considered in the future but is not on the roadmap at this time.

If you have any questions, please reach out with any questions or comments … and thank you for being a Media Temple Grid customer!

 

Comments

Related Articles