We have some good news for PHP users on the (gs) Grid-Service. Available for immediate use, (mt) Media Temple has released a new, simple method for dealing with PHP versions and updates. Please read on for more information.

Outdated software leaves you open to hackers, and updating old versions by hand is a pain. To keep you safe and to make site management simpler, we are now providing new version controls with automatic updates.

Updated Controls

The latest PHP versions are now available in the AccountCenter. For each domain hosted with Media Temple, you can choose which version to use.

We recommend choosing the most recent version, as it will be the most secure and ensure compatibility with the latest web apps. For instance, the latest version of WordPress requires PHP 5.2.4 or newer. If you’re using WordPress, be sure to upgrade! It’s pretty easy.

For those of you specifying PHP versions manually, you can learn more about the AddHandlers in our KnowledgeBase article.

Automatic Updates
As new PHP versions are available and others become unsupported, we will be removing old releases and automatically moving you to stable and secure versions. While most websites will be unaffected by these upgrades, we will make sure you receive plenty of notice so only good surprises come your way.

If you have any questions, feel free to add a comment here or join us in the User Forums.

Thanks for reading!